Maven工程运行环境修改(使用Tomcat7和JDK1.8)

新建的maven项目,默认使用的是jdk1.5,测试运行时会报下面几个Warning:

Warning:java:源值1.5已过时,将在末来所有发行版中删除
Warning:java:目标值1.5已过时,将在未来所有发行版中删除
warning:java:要隐惹有关已过时选项的普告,请使用-Xlint:-options

解决办法:在pom.xml的<build>的<plugins>中插入:

<plugin>
  <groupId>org.apache.tomcat.maven</groupId>
  <artifactId>tomcat7-maven-plugin</artifactId>
  <version>2.2</version>
</plugin>
<plugin>
  <groupId>org.apache.maven.plugins</groupId>
  <artifactId>maven-compiler-plugin</artifactId>
  <configuration>
    <target>1.8</target>
    <source>1.8</source>
    <encoding>UTF-8</encoding>
  </configuration>
</plugin>
购买本主题
添加QQ号:703328210咨询购买具体信息。

作者头像
Zblog屋创始人

本主题是一套风格鲜明的主题,适合做SEO,简介易于操作,上手很快。

上一篇: Maven工程中POM文件jar包坐标的依赖范围
下一篇: IDEA中Maven运行WBE项目报Unable to compile class for JSP解决方法

发表评论